PHP 5.3.8 Upgrade (rpm)


いきなりバグが見つかったようで、PHP 5.3.8がリリースされました。
「管理人のヒトリゴト -もみんぎゅぅ-」 PHP5.3.7に重大なバグ
ohtanさん情報ありがとうございます。
それでPHPを5.3.7からアップグレードした時のメモ。

  • Vine Linux 5.2
  • Apache 2.2.19
  • PHP 5.3.8

まずはソースを落とす。

$ apt-get source php5
$ rpm -ivh php5-5.3.7-1vl5.src.rpm

ソースパッケージを落としてきて、ソースを入れ替える。

$ cd ~/rpm/SOURCES
$ rm php-5.3.7.tar.bz2
$ wget http://jp2.php.net/get/php-5.3.8.tar.bz2/from/jp.php.net/mirror

で、バージョンを合わせ、それからApacheをworkerで動かしてるのでspecファイルをいじる。

$ cd ~/rpm/SPECS
$ vi php5-vl.spec

...
Version: 5.3.8
Release: 0%{_dist_release}

./configureに追加
...
--enable-maintainer-zts \
--with-tsrm-pthreads \

で、ビルドする。

$ rpmbuild -bb --clean php5-vl.spec

そしてコーヒーを飲みながら、アップグレードする。

$ cd ../RPMS/x86_64
$ su
# rpm -Uvh php5-5.3.8-0vl5.x86_64.rpm ...


んで、Apacheを再起動する。

# service apache2 restart

Apache2 HTTP Serverを停止中:				[  OK  ]
Apache2 HTTP Serverを起動中:				[  OK  ]